aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorGuillaume Pasquet <dev@etenil.net>2022-03-03 23:18:08 +0000
committerGuillaume Pasquet <dev@etenil.net>2022-03-03 23:18:08 +0000
commit57af17cfa6e08a6fe9bf6d73d401af17dccfa3bb (patch)
treecd550ccf0eb78f360e6813ffdfd3c89d817eb21f /Cargo.toml
parentf797f10c2eda28a221759fc26ddf483f41232604 (diff)
Introduce JSONPath and potentially break old stuff.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 13 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 78e2347..9fd7ba1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "barb"
-version = "0.2.2"
+version = "0.3.0"
edition = "2021"
license = "GPL-3.0-or-later"
description = "Command-line tool to perform file-based HTTP(s) requests."
@@ -14,11 +14,17 @@ categories = ["command-line-utilities","network-programming","web-programming"]
[dependencies]
ureq = { version = "2.3.1", features = ["json"] }
clap = { version = "3.0.14", features = ["derive"] }
+jq-rs = { version = "0.4", optional = true }
serde = "1.0.130"
-serde_json = "1.0.70"
-jsonformat = "1.2.0"
-jq-rs = "0.4.1"
-colored = "2.0.0"
-colored_json = "2.1.0"
+serde_json = "1.0"
+jsonformat = "1.2"
+colored = "2.0"
+colored_json = "2.1"
dotenv = "0.15.0"
-regex = "1.5" \ No newline at end of file
+regex = "1.5"
+jsonpath-rust = "0.1"
+
+
+[features]
+default = []
+jq = ["jq-rs"] \ No newline at end of file